Computing
From the Analytical Engine to the licences that keep code free.
- 1 Notes on the Analytical Engine (Notes A and G)Notes by the Translator (Notes A and G) Ada Lovelace 1843 9.2
- 2 The Laws of Thought, Chapter I: Nature and Design of this WorkAn Investigation of the Laws of Thought — Chapter I: Nature and Design of this Work George Boole 1854 8.8
- 3 Reason Is Nothing but Reckoning: Leviathan, Chapter VLeviathan, Chapter V: Of Reason, and Science Thomas Hobbes 1651 8.7
- 4 Explanation of Binary ArithmeticExplication de l'arithmétique binaire Gottfried Wilhelm Leibniz 1703 8.7
- 5 The Nine Chapters: The Arts of Fractions九章算術·方田(分數諸術) Anonymous (Han dynasty) 50 8.6
- 6 Let Us Calculate: On the Art of CharactersDe arte characteristica ad perficiendas scientias ratione nitentes Gottfried Wilhelm Leibniz c. 1688 8.6
- 7 The GNU Manifesto Richard Stallman 1985 8.6
- 8 The Free Software DefinitionWhat is Free Software? (The Free Software Definition) Free Software Foundation 1986 8.5
- 9 RFC 1958: Architectural Principles of the Internet Brian Carpenter (editor), for the Internet Architecture Board 1996 8.5
- 10 PEP 20: The Zen of PythonPEP 20 – The Zen of Python Tim Peters 2004 8.5
- 11 The SQLite BlessingThe SQLite blessing, and “SQLite Is Public Domain” D. Richard Hipp and the SQLite developers 2001 8.4
- 12 Of the Analytical Engine Charles Babbage 1864 8.3
- 13 Basics of the Unix PhilosophyThe Art of Unix Programming, Chapter 1: Basics of the Unix Philosophy Eric S. Raymond 2003 8.3
- 14 On the Division of Mental Labour: Making Logarithms Like PinsOn the Economy of Machinery and Manufactures, Chapter XX: On the Division of Mental Labour Charles Babbage 1832 8.2
- 15 Darwin among the Machines Samuel Butler 1863 8.2
- 16 Logical Machines Charles Sanders Peirce 1887 8.2
- 17 RFC 2119: Key Words for Requirement LevelsRFC 2119: Key words for use in RFCs to Indicate Requirement Levels Scott Bradner 1997 8.2
- 18 The Craftsman Yan Shi (Liezi)列子·湯問·偃師 Liezi (attributed) 300 8.1
- 19 RFC 1925: The Twelve Networking Truths Ross Callon (editor) 1996 8.1
- 20 A Necessary Notice on the Arithmetic MachineAdvis necessaire à ceux qui auront curiosité de voir la Machine Arithmétique Blaise Pascal 1645 8.0
- 21 RFC 2468: I Remember IANA Vint Cerf 1998 8.0
- 22 The Jargon File: A SelectionThe Jargon File, version 4.4.7 (a selection) Eric S. Raymond (editor) and many contributors 2003 8.0
- 23 An Electric Tabulating System Herman Hollerith 1889 7.9
- 24 PEP 8: A Foolish ConsistencyPEP 8 – Style Guide for Python Code (Introduction; A Foolish Consistency is the Hobgoblin of Little Minds) Guido van Rossum, Barry Warsaw and Alyssa Coghlan 2001 7.9
- 25 The Open Source Definition Open Source Initiative (from the Debian Free Software Guidelines by Bruce Perens) 1998 7.8
- 26 The Author's Preface to the Admirable Table of Logarithms John Napier 1616 7.7
- 27 On a Proposed Analytical Machine Percy Ludgate 1909 7.7
- 28 RFC 1149: IP Datagrams on Avian CarriersRFC 1149: A Standard for the Transmission of IP Datagrams on Avian Carriers David Waitzman 1990 7.7
- 29 Maelzel’s Chess-Player Edgar Allan Poe 1836 7.6
- 30 Mechanical Assistance in Mental Operations: Jevons on the Logic MachineOn the Mechanical Performance of Logical Inference, §§ 1–8 William Stanley Jevons 1870 7.6
- 31 SQLite: Long Term Support, Through the Year 2050Long Term Support D. Richard Hipp and the SQLite developers 2025 7.6
- 32 RFC 2324: Hyper Text Coffee Pot Control ProtocolRFC 2324: Hyper Text Coffee Pot Control Protocol (HTCPCP/1.0) Larry Masinter 1998 7.5
- 33 RFC 2555: 30 Years of RFCs Robert Braden, Joyce K. Reynolds, Steve Crocker, Vint Cerf, Jake Feinler and Celeste Anderson 1999 7.5
- 34 RFC 1087: Ethics and the Internet Internet Activities Board 1989 7.3
- 35 A New Logical Machine Allan Marquand 1885 7.2
- 36 PEP 1: What Is a PEP?PEP 1 – PEP Purpose and Guidelines (What is a PEP?; PEP Audience; PEP Types) Barry Warsaw, Jeremy Hylton, David Goodger and Alyssa Coghlan 2000 7.0
- 37 PEP 257: Docstring ConventionsPEP 257 – Docstring Conventions David Goodger and Guido van Rossum 2001 7.0
- 38 RFC 968: ’Twas the Night Before Start-upRFC 968: ‘Twas the Night Before Start-up’ Vint Cerf 1985 6.9
- 39 RFC 1121: Act One, The PoemsRFC 1121: Act One – The Poems Jon Postel, Leonard Kleinrock, Vint Cerf and Barry Boehm 1989 6.7